Thank You and German User Issues

By | October 29, 2013

So far the number of subscriptions is well above what I expected at this point. Thank you all so much for helping to support me and the site. I can promise that I will be able to remain full time making content with this number of subscribers. Thank you all so much! ^.^

In other news, I’ve been hearing from German users for the last few days saying that they are unable to sign up for subscriptions. I’ve found out that Germany doesn’t allow recurring payments through PayPal (weird).

So as a work around, you can send money directly to my PayPal. You can pay for 3 to 12 months in advance, then once I get the payment I’ll manually set your account to have a subscription for whatever you paid for. Please pay at least 3 months at a time so I don’t need to keep manually setting your account every month.

My PayPal address is: TheSapphireFoxx@gmail.com

Be sure to send me an email when you send the payment so that I know who the payment came from! (include your username on the site)

-SapphireFoxx

SapphireFoxx.com Subscriptions
Next Animation and Continuing GIFS

Leave a Reply

119 Comments on "Thank You and German User Issues"

Notify of

Sort by:   newest | oldest | most voted
Member
12 days 4 hours ago

Paid for 6 months please reactivate

Member
10 days 10 hours ago

i Paid on Paypal ^^

Member
25 days 1 hour ago

Paid for 4 months please reactivate

Member
1 month 8 hours ago

Hey, i have paid 15$ via paypal

Member
2 months 11 hours ago

Hi , i paid for 6 months via Paypal 🙂

Member
2 months 8 days ago

Hi, I just paid to your PayPal account. pls activate my account. Tks

Member
2 months 24 days ago

Hi, i paid for 3 months via paypal.

Member
3 months 8 days ago

I’ve already paid you $5 for your email. Please activate me.

Guest
4 months 22 days ago

Hi!, I paid for 3 months and I had to do it via paypal so when do i get my subscription?

Member
5 months 19 days ago

Hi i paid for 3 months please activate

Member
5 months 28 days ago

paid for a month. Please reactivate…

Member
6 months 1 day ago

Sapphire seems not available at the moment. paid for 3 months and also did not good activated

Member
6 months 1 day ago

Paid yesterday for 3 months and it is still not working.
Please activate my Account!

Member
6 months 6 days ago

Hi, I paid for 3 months. Thank You

Member
6 months 10 days ago

hi, I paid for 3 months. Thank you

Member
6 months 14 days ago

paid 3 days ago for 3 months, send an email to the support too and still nothing 🙁

wpDiscuz